MP11SE Musescore (Linux, Windows, Android) MIDI am MP11SE abspielen?

5 Replies, 248 Views

Ich verstehe leider nicht wie man das hinbekommt: ich verwende Musescore 4 auf Linux (kann aber noetigenfalls auch auf Windows wechseln) und moechte den Piano part einer Partitur via MIDI an mein MP11SE schicken und mit dem dort eingestellten Piano (am besten der default Fluegel) abspielen.

Problem: Offenbar kann das MP11SE kein MIDI over USB oder doch? Wenn nicht, welche Hardware muss man anschaffen um den MIDI output von Musescare auf eine Standard 5 poliges Midikabel zu bekommen?

Gibt es da Unterschiede zwischen dem Support fuer Linux und Windows? Wie funktioniert das mit Musescore auf Android (zb meinem Tablet), kann man das irgendwie dazu bringen MIDI fuer das Keyboard zu erzeugen?

Ich schaffe es uebrigens auch nicht mal, den USB Anschluss des MP11SE fuer irgendwas zu verwenden: egal ob ich meinen Laptop mit Linux oder Windows anschliesse, die Symptome sind:

* am computer sehe ich das USB das MP11SE erkannt hat (auf Linux mit lsusb, bei Windows hoere ich den Anschluss sound)
* aber das MP11SE erkennt nicht dass irgendetwas angeschlossen ist. Wenn ich die USB Taste druecke komme eine Aufforderung dass ich zuerst eine Geraet verbinde.

Die Bedienungsanleitung enthaelt kaum Erklaerungen dazu.
(Dieser Beitrag wurde zuletzt bearbeitet: 08.01.2023, 17:06 von johann-petrak.)
Erste Näherung: scheint ein Problem mit MuseScore 4 zu sein, mit MuseScore 3 kann man im Mixer fuer jeden Part in der Score einen MIDI Channel einstellen.

Wenn man dann am MP11SE "Section" in der MIDI config einstellt und in MuseScore 3 auf dem Kanal sendet der am MP11SE fuer Digital Piano konfiguriert ist klappt es ....

Aber bei mir soweit nur wenn MuseScore 3 unter Windows läuft, unter Linux funktioniert das gar nicht.
Grüß dich!
Ich verwende ein Kawai MP7SE unter Debian 11 mit Rosegarden, Ardour und Reaper. Alles funktioniert einwandfrei. Ich verwende allerdings nicht Musescore.

Welches Linux-Betriebssystem verwendest du?

Bist du schon erfahrener Linux-Benutzer?

Hast du die "alsa-utils" installiert? Falls ja, poste bitte die Ausgabe von "aplay -l".

Herzliche Grüße, Michael
(12.01.2023, 14:56 )Babarosa schrieb: Grüß dich!
Ich verwende ein Kawai MP7SE unter Debian 11 mit Rosegarden, Ardour und Reaper. Alles funktioniert einwandfrei. Ich verwende allerdings nicht Musescore.

Welches Linux-Betriebssystem verwendest du?

Bist du schon erfahrener Linux-Benutzer?

Hast du die "alsa-utils" installiert? Falls ja, poste bitte die Ausgabe von "aplay -l".

Herzliche Grüße, Michael
Danke!

Ich verwende Ubuntu 22.04.

Bin schon erfahren, aber nicht mit audio/midi Smile

Soweit ich mit erinnere braucht man jack und ein ajck plugin um MIDI over USB von/an eine App zu routen?

Im output von aplay -l sollte man den MIDI-over USB anschluss sehen?
Mit "aplay -l" will ich sehen, ob das MP11 als ALSA-MIDI-Gerät erkannt wird oder im Linuxsystem ein JACK-MIDI-Gerät ist.
Mein MP/SE ist als JACK-MIDI-Gerät eingebunden.

Das heißt, ich würde empfehlen, "jack2, qjackctl, a2jmidid" zu installieren. Weitere Info auf Englisch, um das Linuxsystem für Audio/MIDI zu optimieren, erhältst du auf "http://tedfelix.com/linux/linux-midi.html".
Im Anhang findest du einen Screenshot meiner Verbindungen im Jack-System: grün sind Audio-Verbindungen, violett ALSA-MIDI-Geräte und rot JACK-MIDI-Geräte.
Mein MP7SE erscheint violett als 20:USB-MIDI und wird über das rote midi_capture_2 ins System eingebunden.

Nichtsdestotrotz wundert es mich aber, dass unter Windows 10 das MP11 nicht sofort als MIDI-Gerät erscheint.


Angehängte Dateien Thumbnail(s)
   
(13.01.2023, 11:28 )Babarosa schrieb: Mit "aplay -l" will ich sehen, ob das MP11 als ALSA-MIDI-Gerät erkannt wird oder im Linuxsystem ein JACK-MIDI-Gerät ist.
Mein MP/SE ist als JACK-MIDI-Gerät eingebunden.

Das heißt, ich würde empfehlen, "jack2, qjackctl, a2jmidid" zu installieren. Weitere Info auf Englisch, um das Linuxsystem für Audio/MIDI zu optimieren, erhältst du auf "http://tedfelix.com/linux/linux-midi.html".
Im Anhang findest du einen Screenshot meiner Verbindungen im Jack-System: grün sind Audio-Verbindungen, violett ALSA-MIDI-Geräte und rot JACK-MIDI-Geräte.
Mein MP7SE erscheint violett als 20:USB-MIDI und wird über das rote midi_capture_2 ins System eingebunden.

Nichtsdestotrotz wundert es mich aber, dass unter Windows 10 das MP11 nicht sofort als MIDI-Gerät erscheint.

Vielen Dank! Sorry für die späte Antwort, war leider wegen zu viel Arbeit nicht möglich mir das früher anzusehen.
Ich probier das mal aus ...

Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Christbaum ausschalten beim MP11SE alexborg 2 79 17.03.2023, 17:28
Letzter Beitrag: alexborg
  MP6 Unterschied interner Klang zu MIDI-Ansteuerung MatthiasThein 0 74 22.01.2023, 23:25
Letzter Beitrag: MatthiasThein
  Kawai MP11SE - tiefe Töne dröhnen Problem.Fall 2 292 12.01.2023, 13:54
Letzter Beitrag: Problem.Fall
  MP11SE Line-In mit Mobiltelefon / Earphones out verbinden? johann-petrak 0 116 08.01.2023, 11:20
Letzter Beitrag: johann-petrak
  MP11SE Merkwürdiges Nachhallen Gega 3 502 14.11.2022, 15:47
Letzter Beitrag: michaelkunz
  MP11SE Soundeinstellungen knolaim 6 2,870 12.10.2022, 12:36
Letzter Beitrag: HansRudolf52
  Kann das MP11SE Midi SYSEX senden? alexborg 2 930 28.07.2022, 12:28
Letzter Beitrag: alexborg
Music Kawai MP11se - verstimmtes c3 SK Concert Grand Youwie 3 2,543 28.07.2022, 08:46
Letzter Beitrag: Youwie
  MP11SE: seamless transition? Nordlicht 2 1,065 22.07.2022, 20:28
Letzter Beitrag: Nordlicht
  MP11SE Display schutzfolie?? Geert Molenaar 0 643 01.01.2022, 00:45
Letzter Beitrag: Geert Molenaar



Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste